Snapon Diagnostics Product Forums Diagnostic Home . Diagnostic Product Index . Customer Care        
Diagnostic SoftwareDiagnostic PlatformsAsk-a-Tech, Automotive Repair InformationTech Central
Go Back   Snapon Diagnostics Product Forums > Member General Discussion Forum > General Discussions > US Member User Group
Home Today's Posts Register Members List FAQ
Thank you for visiting Snap-on Diagnostics Product Forums.
You are currently NOT logged in to a registered account. Some functions of Snap-on Diagnostics Product Forums will not be available to you if your are not logged in as a registered member. For a limited time only, registrationto Snap-on Diagnostics Product Forums to Snap-on Diagnostics Product Forums is !! FREE !! Select the    **REGISTER NOW**    link to register for your FREE Snap-on Diagnostics Product Forums account!!

Reply
 
Thread Tools Display Modes
  #1  
Old 05-26-2018, 11:08 PM
Witsend Witsend is offline
Senior Member
 
Join Date: Nov 2012
Posts: 2,542
Witsend Made it to level 2!  Looks like you are on your way to becoming famous

Default Separating corroded Ford Quick Connect AC tubes

My Old Ford Explorer AC compressor performance is fading and not blowing very cold especially at idle. wanted to remove and inspect the orifice tube in the evaporator inlet and change it out, but corrosion that set in made it necessary to use penetrant and a offset pick to get the crud and hard oxidation worked out to defossillize the garter spring and still would not twist side to side without heating around with a propane torch . I was eventually able to successfully twist the connecting liquid line side to side without busting my evaporator inlet tube , but it was dicey and if not patient would have broken evaporator tube if I didn't carefully repeatedly heat it a couple times. Orifice tube was loaded with sh@t . I got a $2 Santech one from autozone, evacuated and recharged AC and seems to work better enough with a new orifice tube , I'll see if the compressor can make it through the summer.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -7. The time now is 03:19 PM.


Reminder: Your participation in these areas of the site is solely at your own risk. The
information is only the opinion of the poster, is no substitute for your own research,
and should not be relied upon for business critical decisions or any other purpose.
Never assume that you are anonymous and cannot be identified by your posts.
We reserve the right to discontinue any users' use of any such public forum
for any reason. Please read the Terms of Service.

Snap-on is a trademark, registered in the United States and other countries, of Snap-on Incorporated. Other marks are marks of their respective holders.
©2009 Snap-on Incorporated. All rights reserved.