Snapon Diagnostics Product Forums Diagnostic Home . Diagnostic Product Index . Customer Care        
Diagnostic SoftwareDiagnostic PlatformsAsk-a-Tech, Automotive Repair InformationTech Central
Go Back   Snapon Diagnostics Product Forums > Snap-on Diagnostic Products > Diagnostic Platforms > SolusUltra User Forum
Home Today's Posts Register Members List FAQ
Thank you for visiting Snap-on Diagnostics Product Forums.
You are currently NOT logged in to a registered account. Some functions of Snap-on Diagnostics Product Forums will not be available to you if your are not logged in as a registered member. For a limited time only, registrationto Snap-on Diagnostics Product Forums to Snap-on Diagnostics Product Forums is !! FREE !! Select the    **REGISTER NOW**    link to register for your FREE Snap-on Diagnostics Product Forums account!!

Reply
 
Thread Tools Display Modes
  #1  
Old 03-08-2019, 07:12 AM
tech25's Avatar
tech25 tech25 is offline
Senior Member
 
Join Date: Oct 2017
Location: florida
Posts: 100
tech25 Congratulations!  Your peers have given you enough reputation to put you into the fist level!

Default missing modules in BMW 5 series

have a 2006 BMW 530xi ( E61 ) scanning with solus ultra with 18.2.1
I have many modules the snap on scan tool does not read.

see the screen shots from the snap on solus

and compare that to a scan from BMW ISTA that scans all modules

I highlighted the modules the snap on module can read, as you can see it is missing about half of the modules, most notable..all the infotainment modules,
this car has air suspension in the rear axle, also missing that module ( EHC )

however, if i choose to do a code scan, it appears to scan for the sunroof ( shd ) the alarm siren ( sine ) the controller ( con ) and the b pillar satellites, ( sbsl, and sbsr ) also does userinterface/radio... ?????

why would it scan those modules in the code scan but they are not shown and able to select on the main module screen ?

this is a 13 year old car, snap on... fix and/or add missing modules for BMW, and release the update in a service release!!! DO NOT add this in a sw update for 19.2 that people would have to purchase!!!
Attached Images
File Type: jpg E61 PIC 1.jpg (100.0 KB, 21 views)
File Type: jpg E61 PIC 2.jpg (103.5 KB, 21 views)
File Type: jpg E61 PIC 3.jpg (101.6 KB, 22 views)
File Type: jpg E61 PIC 4.jpg (103.2 KB, 22 views)
File Type: jpg E61 PIC 5.jpg (73.6 KB, 22 views)
File Type: jpg snap on code scan.jpg (222.8 KB, 22 views)
File Type: jpg BMW ISTA scan.jpg (261.8 KB, 21 views)
Reply With Quote
  #2  
Old 03-08-2019, 07:52 AM
Steve6911's Avatar
Steve6911 Steve6911 is online now
Moderator
 
Join Date: Feb 2007
Location: Wantagh, New York
Posts: 1,816
Steve6911 You made it!  You've done a great job ofearning reputation from your peers.  You now have secret access to a new hidden forum!

Default

THANK YOU Adam!!! I will forward your post to the powers that be.
Reply With Quote
  #3  
Old 03-08-2019, 08:23 AM
tech25's Avatar
tech25 tech25 is offline
Senior Member
 
Join Date: Oct 2017
Location: florida
Posts: 100
tech25 Congratulations!  Your peers have given you enough reputation to put you into the fist level!

Default

thank you for forwarding.. had another issue the other day on a volvo, and when i scanned all modules, and then tried to clear all codes it locked up the scan tool and the dash was a christmas tree. reset scan tool and retried, same results.

i had to use VIDA, which had many can faults in the modules, from the solus crashing, was able to clear all faults with vida

alas i was unable to make a report and dont remember exactly the model so no help there.

If reported bugs do get fixed... then i will take reporting and documenting bugs much more seriously.
Reply With Quote
  #4  
Old 03-08-2019, 09:13 AM
Steve6911's Avatar
Steve6911 Steve6911 is online now
Moderator
 
Join Date: Feb 2007
Location: Wantagh, New York
Posts: 1,816
Steve6911 You made it!  You've done a great job ofearning reputation from your peers.  You now have secret access to a new hidden forum!

Default

Yes Adam, bug reports do get fixed. Sometimes quickly sometimes not. It depends on what the developers are working on at the time and how important they feel the issue is. The Volvo issue sounds VERY important so if something like that comes up again PLEASE get as much information as possible. Year, Make, model, full VIN, the tool and software version you are using along with the issue is the minimum needed. Screen shots (if possible) really help along with if a different make tool was able to do the job or correct the issue. I know its a lot of work but it helps make the tool better which is better for all of us! The reports that come is like I got a blue Chevy 2000 and something and the tool won't shut the damn light off..... well those don't get fixed


THANKS again for your help!
Steve
Reply With Quote
  #5  
Old 03-08-2019, 10:03 AM
tech25's Avatar
tech25 tech25 is offline
Senior Member
 
Join Date: Oct 2017
Location: florida
Posts: 100
tech25 Congratulations!  Your peers have given you enough reputation to put you into the fist level!

Default

looking in the solus history, this is the the volvo i was talking about. did a complete vehicle scan, then when attempting to clear all codes, it crashed about half way through and the dash lit up with all types of warning lights.

had to use vida to clear all the faults, ( can related faults in the modules ).
Attached Images
File Type: jpg 2010 Volvo V70.jpg (60.0 KB, 19 views)
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -7. The time now is 04:54 AM.


Reminder: Your participation in these areas of the site is solely at your own risk. The
information is only the opinion of the poster, is no substitute for your own research,
and should not be relied upon for business critical decisions or any other purpose.
Never assume that you are anonymous and cannot be identified by your posts.
We reserve the right to discontinue any users' use of any such public forum
for any reason. Please read the Terms of Service.

Snap-on is a trademark, registered in the United States and other countries, of Snap-on Incorporated. Other marks are marks of their respective holders.
©2009 Snap-on Incorporated. All rights reserved.