Snapon Diagnostics Product Forums Diagnostic Home . Diagnostic Product Index . Customer Care        
Diagnostic SoftwareDiagnostic PlatformsAsk-a-Tech, Automotive Repair InformationTech Central
Go Back   Snapon Diagnostics Product Forums > Snap-on Diagnostic Products > Diagnostic Platforms > Solus/SOLUS PRO User Forum
Home Today's Posts Register Members List FAQ
Thank you for visiting Snap-on Diagnostics Product Forums.
You are currently NOT logged in to a registered account. Some functions of Snap-on Diagnostics Product Forums will not be available to you if your are not logged in as a registered member. For a limited time only, registrationto Snap-on Diagnostics Product Forums to Snap-on Diagnostics Product Forums is !! FREE !! Select the    **REGISTER NOW**    link to register for your FREE Snap-on Diagnostics Product Forums account!!

Reply
 
Thread Tools Display Modes
  #1  
Old 07-21-2022, 01:05 PM
PLohr PLohr is offline
Junior Member
 
Join Date: Jun 2018
Location: Knoxville
Posts: 14
PLohr Congratulations!  Your peers have given you enough reputation to put you into the fist level!

Default Solus Pro with a 2003 Dodge Ram (Cummins)

Hello,

Working with a Solus Pro, bundle 10.2, software revision 2.6.0, build 6525. The OBD2 connector's part number is MT2500-46B.

I am having trouble getting this scanner to connect to a 2003 Dodge Ram 3500 (Cummins diesel) 2WD M/T. I haven't been able to connect to the engine or transmission computer. I have been able to connect to the ABS, Airbag and Body computers.

The Solus Pro said to use the K25 personality key. I did that. It said to turn the key off then start the engine. I did that. I turned the key off and on several times. Still, it could not connect to the engine computer.

The process for the transmission computer was the same. It never did connect. I would be satisfied with only connecting to the engine computer.

Looking at the personality key chart, I also tried keys K20 and K25 since those cover some Chrysler vehicles. Neither of those made it connect to the engine or transmission computer.

I connected the scanner to a 2008 GMC Yukon XL to check if it would connect to another vehicle's engine and transmission computer. It sure did, no problem.

Here are some annotated photos as I tried to get the scanner to communicate.
https://share.icloud.com/photos/092o...LGfKBFha6WFxWw

I am fresh out of ideas. Thank you for any help.
Reply With Quote
  #2  
Old 07-21-2022, 09:32 PM
Joe Rappa's Avatar
Joe Rappa Joe Rappa is offline
Snap-on DSD
 
Join Date: Aug 2007
Location: North Carolina
Posts: 2,010
Joe Rappa Made it to level 2!  Looks like you are on your way to becoming famous

Default

The possibilities are, in descending order:
Bad Key
Bad Connector
Bad Cable
Bad scanner software/hardware.

The only way to diagnose it in the field would be to try other keys/cables/connectors.

Joe
__________________
"You don't build a reputation on what you're going to do"
Henry Ford
Reply With Quote
  #3  
Old 07-22-2022, 05:41 AM
PLohr PLohr is offline
Junior Member
 
Join Date: Jun 2018
Location: Knoxville
Posts: 14
PLohr Congratulations!  Your peers have given you enough reputation to put you into the fist level!

Default

Hi, Joe. Thank you for your quick response. A new K-25 personality key is on the way. That's Step One.
Reply With Quote
  #4  
Old 07-22-2022, 09:55 AM
Joe Rappa's Avatar
Joe Rappa Joe Rappa is offline
Snap-on DSD
 
Join Date: Aug 2007
Location: North Carolina
Posts: 2,010
Joe Rappa Made it to level 2!  Looks like you are on your way to becoming famous

Default

What corner of Knoxville are you in? I will be working out that way the week of Aug 8th. We might be able to cross paths. I could bring a spare cable and connector with me if the key doesn't fix it. That way you could test it without having to buy it.
Joe
__________________
"You don't build a reputation on what you're going to do"
Henry Ford
Reply With Quote
  #5  
Old 07-22-2022, 10:04 AM
PLohr PLohr is offline
Junior Member
 
Join Date: Jun 2018
Location: Knoxville
Posts: 14
PLohr Congratulations!  Your peers have given you enough reputation to put you into the fist level!

Default

Thanks, Joe. I appreciate that.

I am located in South Knoxville. I will send you a private message with my address and phone number.
Reply With Quote
  #6  
Old Yesterday, 05:05 AM
PLohr PLohr is offline
Junior Member
 
Join Date: Jun 2018
Location: Knoxville
Posts: 14
PLohr Congratulations!  Your peers have given you enough reputation to put you into the fist level!

Default

It turned out that a cable with one broken connection in one of the wires prevented communication. I was able to find this with a DVM. Purchased a new cable and communication with this vehicle is fine. Thanks for your help guys.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -7. The time now is 10:23 AM.


Reminder: Your participation in these areas of the site is solely at your own risk. The
information is only the opinion of the poster, is no substitute for your own research,
and should not be relied upon for business critical decisions or any other purpose.
Never assume that you are anonymous and cannot be identified by your posts.
We reserve the right to discontinue any users' use of any such public forum
for any reason. Please read the Terms of Service.

Snap-on is a trademark, registered in the United States and other countries, of Snap-on Incorporated. Other marks are marks of their respective holders.
2022 Snap-on Incorporated. All rights reserved.